BIT Check VATID for Virtuemart

Screenshots:
Plugin backend (in Joomla! 3)
Field for Vat ID entry
Error message invalid ID
Marked invalid ID
Message country mismatch
Country mismatch
Error message validation service unavailable
Anderer Preismodifikator:
Verkaufspreis inkl. Preisnachlass
Preis: 14,99 €
(Inkl. 19% MwSt., versandkostenfrei)
Download
Beschreibung

Version 2.1.1

Während die Überprüfung der Umsatzsteueridentifikationsnummer in Virtuemart 1.1 noch ein eingebautes Feature war, steht dies in Virtuemart 2.0 nicht mehr zur Verfügung.
Mit diesem Plugin kann eine vom Kunden eingegebene europäische Umsatzsteueridentifikationsnummer auf ihre Gültigkeit überprüft werden. Die eingesetzten Methoden basieren auf der ursprünglichen, in Virtuemart 1.1 eingebauten, Vorgehensweise, wurden aber erweitert und angepasst.

Features:

  • syntaktische Überprüfung der Nummer durch ein Javascript-Verfahren und
  • Validierung über einen europäischen Server auf tatsächliche Existenz der Nummer (optional)
  • anpassbare Fehlermeldungen
  • Markierung von ungültigen Nummern

Wichtig: Dieses Plugin überprüft lediglich, ob die eingegebene Nummer gültig ist. Um Kunden mit gültiger Nummer einen Einkauf ohne Umsatzsteuer zu ermöglichen, benötigen Sie zusätzlich unser Plugin BIT Change Shopper Group for Virtuemart. Tipp: Das Paket BIT Virtuemart2 EUVAT Paket enthält die beiden benötigten Plugins.

  • Version 2.1.1, 09/2017: Fix von deprecate notices; Umstrukturierungen
  • Version 2.1.0, 04/2017: Verwendung des Joomla! Updaters
  • Version 2.0.9, 05/2016: Änderungen zur Unterstützung von Virtuemart 3.0.16
  • Version 2.0.8, 11/2015: Bereich des Plugins auf der Seite vergrößert
  • Version 2.0.7, 04/2015: kleinere Änderungen
  • Version 2.0.6, 03/2015: kleiner Bugfix
  • Version 2.0.5, 02/2015: kleiner Bugfix
  • Version 2.0.4, 02/2015: Änderungen im AJAX-Handling
  • Version 2.0.3, 01/2015: Option zum Anzeigen von Icons, die den Validierungsprozess visualisieren
  • Version 2.0.2, 01/2015: Kleinere Änderungen
  • Version 2.0.1, 12/2014: Routine zum Checken der Slowakischen IDs geändert
  • Version 2.0.0, 11/2014: Erste Version des Plugins, das mit Joomla!3 und Virtuemart3 kompatibel ist

Unterstützte Sprachen: englisch, deutsch

Systemvoraussetzungen: Joomla 2.5/3, Virtuemart 2.x/3.x


Installation:
Bitte zunächst die zip-Datei auf Ihrem Rechner entpacken. Eine Beschreibung des Setups findet sich in der mitgelieferten installation.pdf.

Nach Bestellung und erfolgter Zahlung erhalten Sie:

  • Eine E-Mail mit Downloadlink, Lizenzschlüssel und Rechnung. Der Download-Link ist 12 Monate gültig, kann 10 mal verwendet werden und zeigt stets auf die aktuelle Version der Erweiterung.
  • Zugriff auf die Erweiterung und Rechnung aus Ihrem Kunden-Account (falls Sie sich registriert haben).
  • Automatische Updates über den Joomla!-Updater für 12 Monate (dazu muss der Lizenschlüssel eingetragen werden).
  • Support bei Problemen und Fragen für 12 Monate.